Simulação da proposta de Infraestrutura Rede Bambu

Introdução

Este documento relata os passos utilizado para simular a rede Bambu.

Descrição das etapas

1. Cenário:



1.1 Descrição das conexões físicas:

Equipamento Porta Conectado com
SW1 - DM4100 1 Controlador
SW1 - DM4100 2 Switch UFBA - Remessa
SW1 - DM4100 13 porta 11 ( switch convencional)
SW1 - DM4100 14 Rede interna da UFBA
SW1 - DM4100 11 porta 13 (openflow)
SW2 - DM4100 2 Switch IFBA - Remessa
SW2 - DM4100 13 porta 11 (convencional)
SW2 - DM4100 14 Rede interna do IFBA
SW2 - DM4100 11 porta 13 (openflow)

1.2 Descrição lógica:

VLAN Descrição Porta Configuração
10 controlador 1 tagged
200 Openflow 13 e 14 tagged
1001 Q-in-Q 2 tagged
1001 Q-in-Q 11 untagged com QinQ external

2. Configuração dos Switchs (SW1 e SW2)

2.1 Em ambos os switchs, precisaremos configurar uma vlan de acesso ao servidor (controlador). Para isso:

  • SW1

conf 
interface vlan 10
 ip address 192.168.10.1/24
 set-member tagged ethernet 1

interface ethernet 1/1
switchport native vlan 10
no shut

  • SW2

conf 
interface vlan 10
 ip address 192.168.10.2/24
 set-member tagged ethernet 2

interface ethernet 1/2
switchport native vlan 10
no shut

Além da vlan, precisamos configurar o acesso ao controlador openflow:

conf
openflow
 controller 192.168.10.200 6633
 strip-fcs
 filter-group-prio 0
 mode reactive
 rate-limit 1024
 min-idle-timeout 10
 idle-timeout-mode adjust
 counters-type packets

2.2 Agora, precisaremos configurar a vlan de acesso as máquinas virtuais via openflow (ambos switchs):

conf 
interface vlan 200
 name teste-of
 openflow enable
 set-member tagged ethernet range 1/13 1/14

interface ethernet range 1/13 1/14
 no loopback-detection
 openflow enable
 no mac-learn
 switchport native vlan 200
 switchport block broadcast ethernet range 1/1 1/28
 switchport block multicast ethernet range 1/1 1/28
 switchport block unicast ethernet range 1/1 1/28

2.3 Por fim, configurar Q-in-Q para transportar as vlans openflow via o tráfego convencional.

interface vlan 1001
 set-member tagged ethernet 1/2
 set-member untagged ethernet range 1/11 

interface ethernet 1/11
 no loopback-detection
 switchport native vlan 1001
 switchport qinq external

Detalhe: Para que o Q-in-Q funcione será necessário desabilitar o SPT.

spanning-tree 1
spanning-tree 1 vlan-group 1

Documentos relacionados